Форум XHTML.ru <!-- по-русски -->

Сайты - по стандартам, но не стандартные сайты!


#1 04.04.2011 09:54

Kolyamba
Новичок
Зарегистрирован: 04.04.2011
Сообщений: 1

Сайт не работает в Опере и Мазиле! Помогите найти ошибку!

В IE и Хроме работает нормально, а в опрере и мазиле повисает!
вот что написано в index:

<html>
    <head>
        <title>Имя сайта</title>
        <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
        <link href="style.css" rel="stylesheet" type="text/css" />
        <link rel="shortcut icon" href="favicon.ico" type="image/x-icon" />
        <script type="text/javascript" src="swfobject.js"></script>
        <script type="text/javascript">
        var flashvars = {};
        var params = {allowFullScreen:true};
        var attributes = {};
        swfobject.embedSWF("website.swf", "nav", "100%", "100%", "9.0.0", "expressInstall.swf",flashvars,params,attributes);
        </script>
        <style>
        body{
            margin-left:0px;
            margin-top:0px;
            margin-right:0px;
            margin-bottom:0px;
        }
        </style>
    </head>
    <body>

        <div id="content" align="center">
                    <div id="nav">
                            <p><a href="http://www.adobe.com/go/getflashplayer"><img src="http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Get Adobe Flash player" /></a></p>
                    </div>
    <div style="display:none"><a href=""></a></div>



    </body>
</html>


Где тут ошибка?

Нет на форуме

 

#2 05.04.2011 00:01

cssview
Новичок
Зарегистрирован: 02.04.2011
Сообщений: 2

Re: Сайт не работает в Опере и Мазиле! Помогите найти ошибку!

1. Поставить DOCTYPE
2. Где закрывающийся тег div#content

Нет на форуме

 

Board footer

Работает на PunBB
© 2002—2005 Rickard Andersson

Вы решили по дорогой цене. Сдать золото но не можете определится?